Email Service Disruption

Incident Report for Iplicit

Resolved

We have identified the root cause within our messaging system, which has now been mitigated. Service is now back to normal and we continue to monitor to assure normal service.
Posted Jun 02, 2025 - 17:02 UTC

Investigating

We are aware of a service disruption impacting our platform email service, this is preventing the sending of iplicit platform messages such as Reset Password, Password change, Verification code, Approval requests.

We are currently investigating this issue as a priority and will update you as more information becomes available.
Posted Jun 02, 2025 - 15:19 UTC
This incident affected: Email Service.