Email Delays

Incident Report for Iplicit

Resolved

We’re pleased to confirm that the earlier delay in email delivery has now been resolved.

Thank you for your patience and understanding
Posted Jul 22, 2025 - 20:49 UTC

Investigating

We are currently experiencing a delay of up to 90 minutes for emails sent from iplicit. Please accept our apologies for this inconvenience and your patience whilst we work to resolve
Posted Jul 22, 2025 - 14:33 UTC
This incident affected: Email Service.